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Introduction

The Stock Movement function in Excel Data Bridge allows users to adjust stock levels by adding or writing off
stock, in line with Sage’s ‘add stock’ and ‘write off stock’ options—eliminating the need for a full stock take.

This function has one template with 1 sheet :- All Fields shows all possible fields
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To add stock or write off stock press the process movements button.
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Map Fields

The table below explains the purpose of each of the fields available to the worksheet: -

Status

GroupByID

MovementType

WriteOffCategory

Code

BRCodeName
BRTraceableType
Warehouse

Bin

Quantity

UnitCostPrice
Date
Reference

2ndReference
Analysis code 1

The following fields can be found on the AllFields sheet

Populated when selecting the process movements button on
the Excel Data Bridge ribbon.

¢ The default status on a successful validation will be Pending
* The default status on a successful creation will be Processed

When attempting to send data to Sage 200, the status field
should either be cleared, or display a status of Pending. Any
other data entered in this field will prevent the data being
sent to Sage 200.

Should an error be returned in this cell when attempting to
post, it will appear in red. The error should be corrected in
the worksheet, and the status field cleared before attempting
to send again

Populate group ID, any lines with the same GroupByID will be
kept together when entering Sage. There is more information
on this below.

Dropdown options - choose Add for add stock and Write Off
to write off stock.

If entering a write off, enter a write off category or right click
cells in this column and select Excel Data Bridge Browse to
select data from Sage 200 to populate.

Enter product code or right click and select browse to
populate selected values.

If code is populated via browse, field will auto populate.

If code is populated via browse, field will auto populate.

Enter warehouse or browse to populate

If warehouse is populated via browse, field will auto populate

Enter quantity. If quantity takes stock holding above
maximum level an error message will appear. If you want to
allow ensure AllowExceedsMaximum in report designer is set
to True

Enter the unit cost price. Leaving this blank will use the
default value entered within Sage 200.

Enter the date required or leave blank to add/write off stock
using today’s date.

Enter reference if required.

Enter second reference if required.

If required enter analysis code 1 or browse to populate
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_ If analysis code 1 in sage has been renamed, change title of
column to match. Eg Region, or error will appear

Analysis code 2 If required enter analysis code 2 or browse to populate

If analysis code 2 in sage has been renamed, change title of
column to match. Eg Region, or error will appear

Analysis code 3 If required enter analysis code 3 or browse to populate

If analysis code 3 in sage has been renamed, change title of
column to match. Eg Region, or error will appear

Memo If required enter memo

StockAccCode If required enter stock account code or browse to populate
StockAccCC If required enter stock account cost centre or browse to
populate

StockAccDept If required enter stock account department or browse to
populate

IssuesAccCode If required enter issues account code or browse to populate

If required enter issues account cost centre or browse to
populate

If required enter issues account department or browse to
populate

Narrative If required enter narrative

The following fields are for traceable items

IdentificationNo Enter batch or serial number if a traceable item. For write off
browse for number

ActualQuantityTraceable Enter quantity for batch or empty if using serial numbers
RecordID Enter traceable record ID if adding to an existing batch or use
browse function

AddNew If creating new batch set to TRUE

SellByDate Enter sell by date if required

UseByDate Enter use by date if required

Using the Stock Movements Worksheet

Movement Type — Add

When adding stock using the Stock Movement function, you will start within the movement type column.
This column has a dropdown, where you can select either Add or Write off. For the purpose of this section of
the guide, we will select Add.

When adding, you can then move across to the Code column. This column has a browse function so you can
right-click within the fields in the column and select Excel Data Bridge Browse
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Once the browse menu option is selected, the browse window will appear — this has retrieved your Sage 200
data and shows you all the available Stock items that can be added. Within the window you can search
within each column to filter the results as required. Once the correct stock item(s) have been found, they can
be selected using the checkboxes on the left. Once all required stock items have been selected, the Submit
button can be pressed and these will be added to the sheet.

- -
& Browse = O >
Submit Select All Dezelect All Cancel [ Insert Rows
[ Code Mame Traceable Type
Aflc Alc Aflc -
o ABBuiltIn/15/0/2 AB Built-In Cookers ... Mon-Traceable
* E 2

BRCodeMame BRTraceableType Wa
ABBuiltin/15/0/2 1AB Built-In Cookers 5ing Mon-Traceable

This will populate the Code column, as well as the BRCodeName and BRTraceableType column.

Now that the stock item has been added to the sheet, we can move across to the Warehouse column. This
column is also browse-able and will show all available warehouses within your Sage 200 company. Similar to
before, you can search and filter the results, selecting the warehouse required for the stock addition. Once
this has been submitted, the Warehouse field as well as the Bin if applicable will be populated.

£ *

2 Warehouse  Bin |
14 12

You can now move across to the next columns. The quantity of each stock item is required, and can be
entered within the Quantity column against each line item. The UnitCostPrice can also be entered, however if
left blank it will remain the default value as set within Sage 200. The date can also be entered, however if it
isn’t it will default to todays date when submitted.

The reference and 2" reference columns can also be filled in with any reference required, however these are
optional fields and can be left blank.

If you are using analysis codes, you will have columns relating to your Sage 200 companies specific analysis
codes, these can be browsed, searched and filtered to submit the value required. Similarly, the Stock Account
Code, Cost Centre and Department columns can also be browsed and populated if required.

If the Stock being added is Traceable, you can enter its batch or serial number within the IdentificationNo
column, and enter the number of traceable items (if the items are batch numbered) within the
ActualQuantityTraceable, if the items are serial numbered you can leave this blank.
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If the items are batch numbered, and you are adding this stock to an existing batch you can
either enter the traceable record ID, or browse within the Record ID column to add the required batch
details.

If you are creating a new batch, the value of TRUE can be added to the AddNew column.

For any stock that requires a sell by date, or use by date, the values of each can be entered into the
respective columns.

Now that all the column details have been entered, we can open the Excel Data Bridge tab within the top
ribbon, and select the “Process Movements” button to add the entered stock into Sage 200.

Movement Type — Write Off

When writing off stock using the Stock Movement function you will start within the movement type column.
This column has a dropdown, where you can select either Add or Write off. For the purpose of this section of
the guide, we will select Write Off.

As we are writing off stock, the write off category will need to be entered within the WriteOffCategory
column. This is a browsable column, which can be done by right clicking the cell and selecting the Excel Data
Bridge Browse menu option.

Clear Contents

Quick Analysis

Sort
Filter

Table

AML

Get Data from Table/Range...
MNew Comment

New MNote

Format Cells...

Pick From Drop-down List...

Excel Data Bridge Browse

Once the browse menu option is selected, the browse window will appear — this has retrieved your Sage 200
data and shows you all the available write off categories. Within the window you can search within each
column to filter the results as required. Once the required category has been found, it should be selected
using the checkbox on the left. The Submit button can then be clicked.

$ Browse

Submit Select All Deselect All Ca

Mame

Alc
: Stock Write Offs




Excel Data Bridge -}@ -
Stock Movements Function

When adding, you can then move across to the Code column. This column has a browse function so you can
right-click within the fields in the column and select Excel Data Bridge Browse

Once the browse menu option is selected, the browse window will appear — this has retrieved your Sage 200
data and shows you all the available Stock items that can be added. Within the window you can search
within each column to filter the results as required. Once the correct stock item(s) have been found, they can
be selected using the checkboxes on the left. Once all required stock items have been selected, the Submit
button can be pressed and these will be added to the sheet.

r )
& Browse = O >
Submit Select All Deselect All Cancel [] Insert Rows
[ Code Mame Traceable Type
Alc Alc Aflc -
W ABBuiltIng15/0/2 AB Built-In Cookers ... Mon-Traceahble
£ *

BRCodeName BRTraceableType Wa
ABBuiltln/15/0/2 1aB Built-In Cookers Sing Mon-Traceable

This will populate the Code column, as well as the BRCodeName and BRTraceableType column.

Now that the stock item has been added to the sheet, we can move across to the Warehouse column. This
column is also browse-able and will show all available warehouses within your Sage 200 company. Similar to
before, you can search and filter the results, selecting the warehouse required for the stock write off. Once
this has been submitted, the Warehouse field as well as the Bin if applicable will be populated.

* Ed

e Warehouse  Bin |
14 12

You can now move across to the next columns. The quantity of each stock item is required, and can be
entered within the Quantity column against each line item. The UnitCostPrice can also be entered, however if
left blank it will remain the default value as set within Sage 200. The date can also be entered, however if it
isn’t it will default to todays date when submitted.

The reference and 2™ reference columns can also be filled in with any reference required, however these are
optional fields and can be left blank.

If you are using analysis codes, you will have columns relating to your Sage 200 companies specific analysis
codes, these can be browsed, searched and filtered to submit the value required. Similarly, the Stock Account
Code, Cost Centre and Department columns can also be browsed and populated if required.

If the Stock being written off is Traceable, you can enter its batch or serial number within the IdentificationNo
column, and enter the number of traceable items (if the items are batch numbered) within the
ActualQuantityTraceable, if the items are serial numbered you can leave this blank.
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If the items are batch numbered, you can either enter the traceable record ID, or browse
within the Record ID column to add the batch details.

Now that all the column details have been entered, we can open the Excel Data Bridge tab within the top
ribbon, and select the “Process Movements” button to add the entered stock into Sage 200.

Group By ID

When completing multiple stocktakes in Sage 200 at once, Excel Data Bridge needs to inform Sage 200 which
lines belong together. It does this by assigning certain fields as “key fields” which can be seen by selecting the
Key Fields button from the ribbon.

KeyField properties detected:

GroupBylD

Any unique data can be entered to keep lines together, such as using numbers 1, 2, 3, 4 or letters a, b, ¢, d.
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The worksheet templates have been created in an Excel table with the correct formatting applied.

Goods Value Tax Value Gross Value

To add additional rows, firstly locate the cell at the bottom
right hand corner of the formatted table.

Goods Value Tax Value Gross Value

Now select the cell then click and drag down on the arrow.

fr— Extra rows will be added with the correct formatting.
% g
=
O
To add additional columns, right click on the Paste Special... 0 1200
column heading where you would like your new O Smart Lookup o 2400
column to appear and select. Insert>Table = =
Columns to the left. Insert ¥ B Table Columns to the Left
Delete 3

A new column will be added, named Column 1. Rename the column in Excel, then refer to the next section
on how to map this column in designer.

(o) » |

Line Date
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Mapping New Columns

To add a column right click on an existing column on the template. Select Insert > Column to the left

% Cut
By Copy
%, Paste Options:
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}
DPREsour(EDE D OPResoul§
v i

Paste Special... <

O Smart Lookup :
Insert 3
Delete 3
Select »
Clear Contents

/A Quick Analysis
Sort >

Once a new column has been added to the template, it can be mapped to the required Sage 200 field.

Click Designer to open the mappings for the template and to locate the field to map the column to.

O % ferver
onfig

@ Map Fields

=t | E

Wersion

ode
LineNo

(OperationComponentQuantity te
P4

Download

OpRescurcefction
OpRescurceDescription
OpResourceExporiToGraphicalPlan
OpResourceFixedLength
OpR FixedQuantity F
OpResourcelineMo OpR LineNo

Click the [+ elipsis to the right of the field. The cell mapping window will appear.

Select the cell range for the column before clicking OK.

The column is now mapped and can be populated in Excel Data Bridge.
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Deleting Unwanted Columns

To delete an unwanted column in a template complete the following steps.

Remove the field mapping from the designer. To do this open the designer to view the mapping.

vu | N EE 8 g amamen o & Produ
ew ’ S x
Audel & Map Fields 0

H

Clear the data in mapping field. Close the designer then click Validate Design to check for errors.

Lastly remove the column from the template. Right click the column heading and select Delete>Table
Columns.

* * TraceableDetails

IssuesAccCC

ﬁ:‘l Paste Options:

Co

Insert >
Delete >
Select >
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